about summary refs log tree commit diff
path: root/third_party/nix/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke Granger-Brown <hg@lukegb.com>2020-06-21T16·23+0100
committerlukegb <lukegb@tvl.fyi>2020-06-21T20·42+0000
commit8b83e0f31b7d4b56718a634ebdbc22b18728d384 (patch)
treec89e89c939c4a21141f4b8460e2f87c3fcb350db /third_party/nix/CMakeLists.txt
parent739a45f9e47f35680117af61dc1a3aa2f5615636 (diff)
feat(3p/nix): install pkgconfig files for libexpr, libmain and libstore r/1052
Also fixes the pkgconfig files to use the corresponding CMake variables.

Change-Id: I8095b8aff39ad91e592f3edc95555c9f1f1f153d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/545
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'third_party/nix/CMakeLists.txt')
-rw-r--r--third_party/nix/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/third_party/nix/CMakeLists.txt b/third_party/nix/CMakeLists.txt
index 24de6824de..f325f5a5d9 100644
--- a/third_party/nix/CMakeLists.txt
+++ b/third_party/nix/CMakeLists.txt
@@ -9,6 +9,7 @@ set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
 
 # Provide an output path for pkgconfig.
 include(GNUInstallDirs)
+set(PKGCONFIG_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
 
 # The following lines import CMake-native dependencies which may
 # contain useful definitions. Other dependencies are not treated