about summary refs log tree commit diff
path: root/third_party/nix/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-07-05T16·46+0100
committertazjin <mail@tazj.in>2020-07-05T16·54+0000
commit7e8a48c82c52c9ce39100902ac31dd075577eded (patch)
treed20e09b092084367370d5dbc9d22f09d23d22e1a /third_party/nix/CMakeLists.txt
parent5cb6e6ee21431349ec31cccebf9ab9a56e904bb2 (diff)
fix(3p/nix): Link to glog built by Nix r/1212
Same as cl/921, it seems that the trick to making this work is indeed
overriding the C++ standard used in the dependency.

Change-Id: I3c5984d71014d774c161ecc283844f504fd44719
Reviewed-on: https://cl.tvl.fyi/c/depot/+/922
Tested-by: BuildkiteCI
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'third_party/nix/CMakeLists.txt')
-rw-r--r--third_party/nix/CMakeLists.txt9
1 files changed, 2 insertions, 7 deletions
diff --git a/third_party/nix/CMakeLists.txt b/third_party/nix/CMakeLists.txt
index 35fc003dd7..58a1fe23fc 100644
--- a/third_party/nix/CMakeLists.txt
+++ b/third_party/nix/CMakeLists.txt
@@ -17,16 +17,11 @@ set(PKGCONFIG_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
 find_package(BZip2)
 find_package(Boost COMPONENTS context) # probably coroutine + ::headers, lets find out
 find_package(CURL)
+find_package(LibLZMA)
 find_package(SQLite3)
 find_package(Threads)
-find_package(LibLZMA)
 find_package(absl REQUIRED)
-
-# Linking precompiled glog binaries (linked against libstdc++) leads
-# to working binaries that do not output log messages. It seems that
-# in order to use glog with LLVM & libc++, one needs to make glog a
-# part of the local project build.
-add_subdirectory(glog)
+find_package(glog REQUIRED)
 
 # generate a configuration file (autoheader-style) to configure
 # certain symbols that Nix depends on.