about summary refs log tree commit diff
path: root/third_party/nix/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke Granger-Brown <hg@lukegb.com>2020-06-21T20·41+0100
committerlukegb <lukegb@tvl.fyi>2020-06-21T23·49+0000
commit4de63f784c53f5400cc454f6faadc907b34f4ac2 (patch)
tree086a57f03f5a2b94dcc7c67ff67bad883a3125c0 /third_party/nix/CMakeLists.txt
parentb99829f142a6de8360e282348b60b4c3c0f210b5 (diff)
fix(3p/nix): propagate dependencies which are needed by people linking in nix r/1055
This includes absl, which we install into the output, and boost and the boehm GC,
which are moved to propagated deps.

Change-Id: I8f9f9795ff92e26b2320359064241d7fd59c2d33
Reviewed-on: https://cl.tvl.fyi/c/depot/+/549
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'third_party/nix/CMakeLists.txt')
-rw-r--r--third_party/nix/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/third_party/nix/CMakeLists.txt b/third_party/nix/CMakeLists.txt
index 54bf362332..fad650a7ca 100644
--- a/third_party/nix/CMakeLists.txt
+++ b/third_party/nix/CMakeLists.txt
@@ -30,6 +30,14 @@ find_package(LibLZMA)
 # builds this symlink is automatically replaced with an appropriate
 # link to the Abseil sources in the Nix store.
 add_subdirectory(abseil_cpp)
+install(DIRECTORY abseil_cpp/absl
+  DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+  FILES_MATCHING
+    PATTERN "*.inc"
+    PATTERN "*.h"
+    PATTERN "copts" EXCLUDE
+    PATTERN "testdata" EXCLUDE
+  )
 
 # Linking precompiled glog binaries (linked against libstdc++) leads
 # to working binaries that do not output log messages. It seems that