about summary refs log tree commit diff
path: root/third_party/lisp/usocket.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-01-21T02·06+0000
committerVincent Ambo <tazjin@google.com>2020-01-21T02·07+0000
commit6de462f674affc4407b89ffe356c2159efad353c (patch)
treefebc9f4d76a3ff5c9d9e74a90fb3504836609f39 /third_party/lisp/usocket.nix
parente50c669310811d45f1d89b50c359e9b1adbce21d (diff)
feat(third_party/lisp): Check in drakma HTTP client & deps r/436
This HTTP client has much fewer dependencies than some of the other
ones I've seen, and it'll be good enough for my demo purposes.
Diffstat (limited to '')
-rw-r--r--third_party/lisp/usocket.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/third_party/lisp/usocket.nix b/third_party/lisp/usocket.nix
new file mode 100644
index 0000000000..16f2003a33
--- /dev/null
+++ b/third_party/lisp/usocket.nix
@@ -0,0 +1,35 @@
+# Usocket is a portable socket library
+{ pkgs, ... }:
+
+let src = pkgs.third_party.fetchFromGitHub {
+  owner = "usocket";
+  repo = "usocket";
+  rev = "fdf4fd1e0051ce83340ccfbbc8a43a462bb19cf2";
+  sha256 = "0x746wr2324l6bn7skqzgkzcbj5kd0zp2ck0c8rldrw0rzabg826";
+};
+in pkgs.nix.buildLisp.library {
+  name = "usocket";
+  deps = with pkgs.third_party.lisp; [
+    asdf
+    sb-bsd-sockets
+    split-sequence
+  ];
+
+  srcs = [
+    # usocket also reads its version from ASDF, but there's further
+    # shenanigans happening there that I don't intend to support right
+    # now. Behold:
+    (builtins.toFile "usocket.asd" ''
+      (in-package :asdf)
+      (defsystem usocket
+        :version "0.8.3")
+    '')
+  ] ++
+  # Now for the regularly scheduled programming:
+  (map (f: src + ("/" + f)) [
+    "package.lisp"
+    "usocket.lisp"
+    "condition.lisp"
+    "backend/sbcl.lisp"
+  ]);
+}