about summary refs log tree commit diff
path: root/third_party/lisp/trivial-ldap.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-07-21T22·53-0400
committerglittershark <grfn@gws.fyi>2020-07-23T00·08+0000
commit08397fd7579c32a9a1d9bdd1b33abce9209f7c47 (patch)
treed831babe8fae1ef883d97ef4ffbf5db5a4a334c6 /third_party/lisp/trivial-ldap.nix
parentef64479c9dbd590c50eee27b21596102024f8bc5 (diff)
feat(3p/lisp): Add many packages r/1420
Add the following packages along with their transitive dependencies:
- trivial-ldap
- defclass-std
- easy-routes

Change-Id: Ib24517f18d14d57540362132c9a24ff2a5a4bd9d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1336
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: kanepyork <rikingcoding@gmail.com>
Diffstat (limited to '')
-rw-r--r--third_party/lisp/trivial-ldap.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/third_party/lisp/trivial-ldap.nix b/third_party/lisp/trivial-ldap.nix
new file mode 100644
index 0000000000..aed651239d
--- /dev/null
+++ b/third_party/lisp/trivial-ldap.nix
@@ -0,0 +1,22 @@
+{ depot, pkgs, ... }:
+
+let src = pkgs.fetchFromGitHub {
+    owner = "rwiker";
+    repo = "trivial-ldap";
+    rev = "3b8f1ff85f29ea63e6ab2d0d27029d68b046faf8";
+    sha256 = "1zaa4wnk5y5ff211pkg6dl27j4pjwh56hq0246slxsdxv6kvp1z9";
+  };
+in depot.nix.buildLisp.library {
+  name = "trivial-ldap";
+
+  deps = with pkgs.lisp; [
+    usocket
+    cl-plus-ssl
+    cl-yacc
+  ];
+
+  srcs = map (f: src + ("/" + f)) [
+    "package.lisp"
+    "trivial-ldap.lisp"
+  ];
+}