about summary refs log tree commit diff
path: root/third_party/lisp/sclf/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2022-07-04T13·56+0200
committerclbot <clbot@tvl.fyi>2022-07-05T15·01+0000
commit49aee7a8f283069a3b47a2617a448389fe8c4373 (patch)
treeb6d2102124ad161a4f047c656e76b89a499b61d1 /third_party/lisp/sclf/default.nix
parentc08e47903e19e9a5ea397430e690680d91c5a9ac (diff)
chore: remove sclf from the tree r/4275
SCLF is quite a big utility library (almost 3€ LOC) with limited
portability (CMUCL, SBCL and CLISP to an extent). Continuing to maintain
it is an unnecessary burden, as depot only uses a fraction of it which
is now inlined into the respective users (mime4cl and mblog).

In the future trimming down ex-sclf.lisp may make sense either by
refactoring the code that uses it or by moving interesting utilities
into e.g. klatre.

Change-Id: I2e73825b6bfa372e97847f25c30731a5aad4a1b5
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5922
Tested-by: BuildkiteCI
Autosubmit: sterni <sternenseemann@systemli.org>
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'third_party/lisp/sclf/default.nix')
-rw-r--r--third_party/lisp/sclf/default.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/third_party/lisp/sclf/default.nix b/third_party/lisp/sclf/default.nix
deleted file mode 100644
index fb07f8f764e5..000000000000
--- a/third_party/lisp/sclf/default.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright (C) 2021 by the TVL Authors
-# SPDX-License-Identifier: LGPL-2.1-or-later
-{ depot, pkgs, ... }:
-
-depot.nix.buildLisp.library {
-  name = "sclf";
-
-  deps = [
-    (depot.nix.buildLisp.bundled "sb-posix")
-  ];
-
-  srcs = [
-    ./package.lisp
-    ./sclf.lisp
-    ./sysproc.lisp
-    ./lazy.lisp
-    ./time.lisp
-    ./directory.lisp
-    ./serial.lisp
-    ./mp/sbcl.lisp
-  ];
-
-  # TODO(sterni): implement OS interaction for ECL and CCL
-  brokenOn = [
-    "ecl"
-    "ccl"
-  ];
-}