about summary refs log tree commit diff
path: root/third_party/lisp/s-xml/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-12-15T21·51+0300
committertazjin <mail@tazj.in>2021-12-15T22·09+0000
commitdb742c2035f9cfcf496b4a9b1640d1cf623a2c0f (patch)
treea9bcaf6632d910ae68185319cc5bcd408667a8d9 /third_party/lisp/s-xml/default.nix
parent75ca24c60a57ab894da4d404755b8b4094284ad8 (diff)
chore(3p/lisp): use nixpkgs sources for s-xml r/3258
this one was a little more difficult because it needs a patch, there's
something wonky with the definition order

fwiw, the upstream cvs repository ... server errors.

Change-Id: I2d99359edec36b578389f1be1fcf077743c29c4e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4342
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'third_party/lisp/s-xml/default.nix')
-rw-r--r--third_party/lisp/s-xml/default.nix28
1 files changed, 17 insertions, 11 deletions
diff --git a/third_party/lisp/s-xml/default.nix b/third_party/lisp/s-xml/default.nix
index 82b6317f372c..3cd13ffb6b67 100644
--- a/third_party/lisp/s-xml/default.nix
+++ b/third_party/lisp/s-xml/default.nix
@@ -1,17 +1,23 @@
 # XML serialiser for Common Lisp.
-#
-# This system was imported from a Quicklisp tarball at 's-xml-20150608'.
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
-depot.nix.buildLisp.library {
+let src = pkgs.applyPatches {
+  name = "s-xml-source";
+  src = pkgs.lispPackages.s-xml.src;
+
+  patches = [
+    ./0001-fix-definition-order-in-xml.lisp.patch
+  ];
+};
+in depot.nix.buildLisp.library {
   name = "s-xml";
 
-  srcs = [
-    ./src/package.lisp
-    ./src/xml.lisp
-    ./src/dom.lisp
-    ./src/lxml-dom.lisp
-    ./src/sxml-dom.lisp
-    ./src/xml-struct-dom.lisp
+  srcs = map (f: src + ("/src/" + f)) [
+    "package.lisp"
+    "xml.lisp"
+    "dom.lisp"
+    "lxml-dom.lisp"
+    "sxml-dom.lisp"
+    "xml-struct-dom.lisp"
   ];
 }