about summary refs log tree commit diff
path: root/third_party/lisp/routes.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-07-21T22·53-0400
committerglittershark <grfn@gws.fyi>2020-07-23T00·08+0000
commit08397fd7579c32a9a1d9bdd1b33abce9209f7c47 (patch)
treed831babe8fae1ef883d97ef4ffbf5db5a4a334c6 /third_party/lisp/routes.nix
parentef64479c9dbd590c50eee27b21596102024f8bc5 (diff)
feat(3p/lisp): Add many packages r/1420
Add the following packages along with their transitive dependencies:
- trivial-ldap
- defclass-std
- easy-routes

Change-Id: Ib24517f18d14d57540362132c9a24ff2a5a4bd9d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1336
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: kanepyork <rikingcoding@gmail.com>
Diffstat (limited to 'third_party/lisp/routes.nix')
-rw-r--r--third_party/lisp/routes.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/third_party/lisp/routes.nix b/third_party/lisp/routes.nix
new file mode 100644
index 0000000000..61c6749660
--- /dev/null
+++ b/third_party/lisp/routes.nix
@@ -0,0 +1,28 @@
+{ depot, pkgs, ... }:
+
+let
+
+  src = pkgs.fetchFromGitHub {
+    owner = "archimag";
+    repo = "cl-routes";
+    rev = "1b79e85aa653e1ec87e21ca745abe51547866fa9";
+    sha256 = "1zpk3cp2v8hm50ppjl10yxr437vv4552r8hylvizglzrq2ibsbr1";
+  };
+
+in depot.nix.buildLisp.library {
+  name = "routes";
+
+  deps = with depot.third_party.lisp; [
+    puri
+    iterate
+    split-sequence
+  ];
+
+  srcs = map (f: src + ("/src/" + f)) [
+    "package.lisp"
+    "uri-template.lisp"
+    "route.lisp"
+    "mapper.lisp"
+  ];
+
+}