about summary refs log tree commit diff
path: root/third_party/lisp/rfc2388.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-01-22T00·23+0000
committerVincent Ambo <tazjin@google.com>2020-01-22T00·23+0000
commitfe3ea06cbc32c9b727549a6505e69234f3072f6f (patch)
tree0fca475404528540bcf1bef98f9360ba67c828a2 /third_party/lisp/rfc2388.nix
parent6de462f674affc4407b89ffe356c2159efad353c (diff)
feat(third_party/lisp): Add derivations for hunchentoot & deps r/437
Diffstat (limited to 'third_party/lisp/rfc2388.nix')
-rw-r--r--third_party/lisp/rfc2388.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/third_party/lisp/rfc2388.nix b/third_party/lisp/rfc2388.nix
new file mode 100644
index 0000000000..863bb3f9ac
--- /dev/null
+++ b/third_party/lisp/rfc2388.nix
@@ -0,0 +1,17 @@
+# Implementation of RFC2388 (multipart/form-data)
+{ pkgs, ... }:
+
+let src = pkgs.third_party.fetchFromGitHub {
+  owner = "jdz";
+  repo = "rfc2388";
+  rev = "591bcf7e77f2c222c43953a80f8c297751dc0c4e";
+  sha256 = "0phh5n3clhl9ji8jaxrajidn22d3f0aq87mlbfkkxlnx2pnw694k";
+};
+in pkgs.nix.buildLisp.library {
+  name = "rfc2388";
+
+  srcs = map (f: src + ("/" + f)) [
+    "packages.lisp"
+    "rfc2388.lisp"
+  ];
+}