about summary refs log tree commit diff
path: root/third_party/lisp/restas.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-07-21T22·53-0400
committerglittershark <grfn@gws.fyi>2020-07-23T00·08+0000
commit08397fd7579c32a9a1d9bdd1b33abce9209f7c47 (patch)
treed831babe8fae1ef883d97ef4ffbf5db5a4a334c6 /third_party/lisp/restas.nix
parentef64479c9dbd590c50eee27b21596102024f8bc5 (diff)
feat(3p/lisp): Add many packages r/1420
Add the following packages along with their transitive dependencies:
- trivial-ldap
- defclass-std
- easy-routes

Change-Id: Ib24517f18d14d57540362132c9a24ff2a5a4bd9d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1336
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: kanepyork <rikingcoding@gmail.com>
Diffstat (limited to 'third_party/lisp/restas.nix')
-rw-r--r--third_party/lisp/restas.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/third_party/lisp/restas.nix b/third_party/lisp/restas.nix
new file mode 100644
index 0000000000..8a0b5f907f
--- /dev/null
+++ b/third_party/lisp/restas.nix
@@ -0,0 +1,38 @@
+{ depot, pkgs, ... }:
+
+let
+
+  src = pkgs.fetchFromGitHub {
+    owner = "archimag";
+    repo = "restas";
+    rev = "81bbbab6b36f81f846f78e71232e9d3d15f6d952";
+    sha256 = "00ng6jik1lwjw3bbxhijy8s0ml24lgm73liwrr01gcsb0r6wrjjn";
+  };
+
+in depot.nix.buildLisp.library {
+  name = "restas";
+  deps = with depot.third_party.lisp; [
+    cffi
+    hunchentoot
+    bordeaux-threads
+    routes
+    alexandria
+    data-sift
+  ];
+
+  srcs = map (f: src + ("/src/" + f)) [
+    "packages.lisp"
+    "special.lisp"
+    "declarations.lisp"
+    "errors.lisp"
+    "render.lisp"
+    "context.lisp"
+    "module.lisp"
+    "route.lisp"
+    "decorators.lisp"
+    "vhost.lisp"
+    "hunchentoot.lisp"
+    "policy.lisp"
+  ];
+
+}