about summary refs log tree commit diff
path: root/third_party/lisp/puri.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-01-21T02·06+0000
committerVincent Ambo <tazjin@google.com>2020-01-21T02·07+0000
commit6de462f674affc4407b89ffe356c2159efad353c (patch)
treefebc9f4d76a3ff5c9d9e74a90fb3504836609f39 /third_party/lisp/puri.nix
parente50c669310811d45f1d89b50c359e9b1adbce21d (diff)
feat(third_party/lisp): Check in drakma HTTP client & deps r/436
This HTTP client has much fewer dependencies than some of the other
ones I've seen, and it'll be good enough for my demo purposes.
Diffstat (limited to 'third_party/lisp/puri.nix')
-rw-r--r--third_party/lisp/puri.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/third_party/lisp/puri.nix b/third_party/lisp/puri.nix
new file mode 100644
index 0000000000..1ac22a3996
--- /dev/null
+++ b/third_party/lisp/puri.nix
@@ -0,0 +1,15 @@
+# Portable URI library
+{ pkgs, ... }:
+
+let src = builtins.fetchGit {
+  url = "http://git.kpe.io/puri.git";
+  rev = "ef5afb9e5286c8e952d4344f019c1a636a717b97";
+};
+in pkgs.nix.buildLisp.library {
+  name = "puri";
+  srcs = [
+    (src + "/src.lisp")
+  ];
+}
+
+