about summary refs log tree commit diff
path: root/third_party/lisp/prove.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-01-23T16·31+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-01-23T16·31+0000
commite76843d337546fe83dbbc9eba9cff52ca6767ef7 (patch)
treed84c362758d6926715ef597d5501e14918549974 /third_party/lisp/prove.nix
parent393bd0a5c7967c9eafbf228413416d7691125e59 (diff)
Create third_party
Create a third_party subdirectory and a third_party/lisp. This directory layout
resembles and is inspired by the layout of Google's mono-repo, Google3. @tazjin
borrowed this idea from Google and I'm borrowing the idea from him.
Diffstat (limited to 'third_party/lisp/prove.nix')
-rw-r--r--third_party/lisp/prove.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/third_party/lisp/prove.nix b/third_party/lisp/prove.nix
new file mode 100644
index 0000000000..d6c0fe7413
--- /dev/null
+++ b/third_party/lisp/prove.nix
@@ -0,0 +1,35 @@
+{
+  depot ? import <depot> {},
+  universe? import <universe> {},
+  ...
+}:
+
+let
+  src = builtins.fetchGit {
+    url = "https://github.com/fukamachi/prove.git";
+    rev = "5d71f02795b89e36f34e8c7d50e69b67ec6ca2de";
+  };
+in depot.nix.buildLisp.library {
+  name = "prove";
+  deps = [
+    depot.third_party.lisp.cl-ppcre
+    depot.third_party.lisp.cl-ansi-text
+    depot.third_party.lisp.alexandria
+    depot.third_party.lisp.uiop
+    universe.third_party.lisp.cl-colors
+  ];
+  srcs = [
+    "${src}/src/asdf.lisp"
+    "${src}/src/suite.lisp"
+    "${src}/src/color.lisp"
+    "${src}/src/output.lisp"
+    "${src}/src/prove.lisp"
+    "${src}/src/report.lisp"
+    "${src}/src/reporter.lisp"
+    "${src}/src/test.lisp"
+    "${src}/src/reporter/dot.lisp"
+    "${src}/src/reporter/fiveam.lisp"
+    "${src}/src/reporter/list.lisp"
+    "${src}/src/reporter/tap.lisp"
+  ];
+}