about summary refs log tree commit diff
path: root/third_party/lisp/postmodern.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-10T00·13+0200
committertazjin <mail@tazj.in>2021-04-10T11·48+0000
commit8361b82d0ac59f436f7ecef283077b0f7d689ca1 (patch)
tree15f9649ae9f3381c7218ea4f46fc9979a12f11bd /third_party/lisp/postmodern.nix
parent8d4b2f3d54e760ab9f7f8242370a54ff20796553 (diff)
refactor(third_party): Consistent use of depot.third_party vs. pkgs r/2461
In preparation for the solution of b/108, we need to consistently use
`depot.third_party` for packages that are only packed in the TVL depot
and `pkgs` for things that come from nixpkgs.

This commit cleans up a huge chunk of these uses in //third_party

Change-Id: Ic382c0cdea7330a84d5f0b7d109c824ddceb94e7
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2912
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'third_party/lisp/postmodern.nix')
-rw-r--r--third_party/lisp/postmodern.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/third_party/lisp/postmodern.nix b/third_party/lisp/postmodern.nix
index cc133eeb89..e50e65f1c1 100644
--- a/third_party/lisp/postmodern.nix
+++ b/third_party/lisp/postmodern.nix
@@ -12,7 +12,7 @@ let
 
   cl-postgres = depot.nix.buildLisp.library {
     name = "cl-postgres";
-    deps = with pkgs.lisp; [
+    deps = with depot.third_party.lisp; [
       md5
       split-sequence
       ironclad
@@ -44,7 +44,7 @@ let
 
   s-sql = depot.nix.buildLisp.library {
     name = "s-sql";
-    deps = with pkgs.lisp; [
+    deps = with depot.third_party.lisp; [
       cl-postgres
       alexandria
     ];
@@ -58,7 +58,7 @@ let
   postmodern = depot.nix.buildLisp.library {
     name = "postmodern";
 
-    deps = with pkgs.lisp; [
+    deps = with depot.third_party.lisp; [
       alexandria
       cl-postgres
       s-sql