about summary refs log tree commit diff
path: root/third_party/lisp/parseq.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-07-22T20·28-0400
committerglittershark <grfn@gws.fyi>2020-07-23T04·28+0000
commitb1c0866037ea63b670055883de88a9fe4e8891e2 (patch)
treecef4735ba4745239d511cb6885cb538526f17471 /third_party/lisp/parseq.nix
parentf591c32dfb2a9f0246c8d6501c1efab4c80da52f (diff)
feat(3p/lisp): Add LASS r/1423
Add LASS, a CSS library

Change-Id: I225959b12210895d0e5baf8a41ac09b0351f0aed
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1349
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'third_party/lisp/parseq.nix')
-rw-r--r--third_party/lisp/parseq.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/third_party/lisp/parseq.nix b/third_party/lisp/parseq.nix
new file mode 100644
index 0000000000..fe045d5299
--- /dev/null
+++ b/third_party/lisp/parseq.nix
@@ -0,0 +1,20 @@
+{ depot, pkgs, ... }:
+
+let
+  src = pkgs.fetchFromGitHub {
+    owner = "mrossini-ethz";
+    repo = "parseq";
+    rev = "5cd95b324b68255d89f27f8065f4c29674558b26";
+    sha256 = "1f3vvxgyiv0xn2hzafhh63l3gnvn2vaxr5pi3ld7d340mka2ndg0";
+  };
+
+in depot.nix.buildLisp.library {
+  name = "parseq";
+
+  srcs = map (f: src + ("/" + f)) [
+    "package.lisp"
+    "conditions.lisp"
+    "utils.lisp"
+    "defrule.lisp"
+  ];
+}