about summary refs log tree commit diff
path: root/third_party/lisp/nibbles.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2021-08-15T16·50+0200
committersterni <sternenseemann@systemli.org>2021-08-15T23·26+0000
commit0bf5b9eb20e9bdf8581132e5ebefa30f5961ae6a (patch)
tree8fb247c179015d3823eeae58784b66124c8e1eae /third_party/lisp/nibbles.nix
parentda09725c30c0085a33cd71e06c5333ad39d6c528 (diff)
feat(3p/lisp/nibbles): 2017-03-07 -> 2021-05-20 r/2740
Also allows us to enable the SBCL opt modules. Upstream changes as
sharplispers has the only maintained nibbles fork atm.

Change-Id: I6f0d1b9e4e570169e5f5c584364948e2031063af
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3364
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to '')
-rw-r--r--third_party/lisp/nibbles.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/third_party/lisp/nibbles.nix b/third_party/lisp/nibbles.nix
index 593bc4b385..ec4e6e6b10 100644
--- a/third_party/lisp/nibbles.nix
+++ b/third_party/lisp/nibbles.nix
@@ -3,10 +3,11 @@
 let
   inherit (depot.nix.buildLisp) bundled;
   src = pkgs.fetchFromGitHub {
-    owner = "froydnj";
+    owner = "sharplispers";
     repo = "nibbles";
-    rev = "9de8c755c2ff24117748a3271e8582bb8d4a6b6c";
-    sha256 = "11rznn33m950mp4zgnpyjaliy3z3rvibfdr8y4vnk2aq42kqi7dj";
+    rev = "dad25240928d5cf8f7df69c4398244e03570bb35";
+    sha256 = "0r6ljlpgjmkf87pmvdwzva8qj15bhznc3ylgcjjqyy4frbx9lygz";
+    name = "nibbles-source";
   };
 
 in depot.nix.buildLisp.library {
@@ -23,5 +24,9 @@ in depot.nix.buildLisp.library {
     "types.lisp"
     "vectors.lisp"
     "streams.lisp"
+    "sbcl-opt/fndb.lisp"
+    "sbcl-opt/nib-tran.lisp"
+    "sbcl-opt/x86-vm.lisp"
+    "sbcl-opt/x86-64-vm.lisp"
   ];
 }