about summary refs log tree commit diff
path: root/third_party/lisp/lisp-binary.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2021-04-11T22·17+0200
committersterni <sternenseemann@systemli.org>2021-04-12T14·00+0000
commit968effb5dc1a4617a0dceaffc70e986abe300c6e (patch)
tree84577ebd4eeeb27c7c02d7aa1ea658843489b244 /third_party/lisp/lisp-binary.nix
parentf39b5a8a0dc94fd5226438791c1291e2f8186f91 (diff)
feat(3p): upgrade sbcl to 2.1.2 r/2484
sbcl 2.0.9 introduced a new warning:

> minor incompatible change: the compiler signals a warning at
> compile-time when an initform of T, NIL or 0 does not match
> a STANDARD-CLASS slot's declared type.

This broke a few packages, but they all have been fixed upstream in the
meantime and we only need to bump their versions. The culprits are:

* defclass-std which possibly has become unmaintained since the fix
  (december 2020).

* cl-prevalence which also needs one symbol from bt now

* lisp-binary which also includes a new file now

Change-Id: I06bb47a129d5ef912a623315c1281aedd1ceac2a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2934
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'third_party/lisp/lisp-binary.nix')
-rw-r--r--third_party/lisp/lisp-binary.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/third_party/lisp/lisp-binary.nix b/third_party/lisp/lisp-binary.nix
index 9019536340..e6111c20a7 100644
--- a/third_party/lisp/lisp-binary.nix
+++ b/third_party/lisp/lisp-binary.nix
@@ -4,8 +4,8 @@
 let src = pkgs.fetchFromGitHub {
   owner = "j3pic";
   repo = "lisp-binary";
-  rev = "1aefc8618b7734f68697ddf59bc93cb8522aa0bf";
-  sha256 = "1hflzn3mjp32jz9fxx9wayp3c3x58s77cgjfbs06nrynqkv0c6df";
+  rev = "052df578900dea59bf951e0a6749281fa73432e4";
+  sha256 = "1i1s5g01aimfq6lndcl1pnw7ly5hdh0wmjp2dj9cjjwbkz9lnwcf";
 };
 in depot.nix.buildLisp.library {
   name = "lisp-binary";
@@ -26,5 +26,6 @@ in depot.nix.buildLisp.library {
     "reverse-stream.lisp"
     "binary-1.lisp"
     "binary-2.lisp"
+    "types.lisp"
   ];
 }