about summary refs log tree commit diff
path: root/third_party/lisp/let-plus.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-12-14T21·00+0300
committerclbot <clbot@tvl.fyi>2021-12-14T21·21+0000
commitb0614b5c83ae62672cb036bebb6ce12675aa3074 (patch)
treeac2a4fafa87dae3a0f452fb54977421db9a21344 /third_party/lisp/let-plus.nix
parent46a2c75a596b292d02d8647dfb44205dd876fd6f (diff)
refactor(3p/lisp): Move things from //users/wpcarro/third_party/lisp r/3245
* move packages and adapt them for the depot structure instead of
  briefcase
* drop linear-programming package, it didn't build anyways

Note that at least some of these packages (e.g. prove) are deprecated
upstream, but lets sort that out later.

Change-Id: I7f5a5faa29d57f060b21ac8e1706090866a82000
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4330
Autosubmit: tazjin <mail@tazj.in>
Reviewed-by: grfn <grfn@gws.fyi>
Reviewed-by: wpcarro <wpcarro@gmail.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'third_party/lisp/let-plus.nix')
-rw-r--r--third_party/lisp/let-plus.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/third_party/lisp/let-plus.nix b/third_party/lisp/let-plus.nix
new file mode 100644
index 0000000000..3afb640e4e
--- /dev/null
+++ b/third_party/lisp/let-plus.nix
@@ -0,0 +1,20 @@
+{ depot, pkgs, ... }:
+
+let
+  src = pkgs.fetchgit {
+    url = "https://github.com/tpapp/let-plus.git";
+    rev = "7cf18b29ed0fe9c667a9a6a101b08ab9661a59e9";
+    hash = "sha256:1xy3b05dwjddk33mah2jaigm4jzsmrxjcc1d0dhsw0krwgr4450f";
+  };
+in depot.nix.buildLisp.library {
+  name = "let-plus";
+  deps = [
+    depot.third_party.lisp.alexandria
+    depot.third_party.lisp.anaphora
+  ];
+  srcs = [
+    "${src}/package.lisp"
+    "${src}/let-plus.lisp"
+    "${src}/extensions.lisp"
+  ];
+}