about summary refs log tree commit diff
path: root/third_party/lisp/lass.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-07-22T20·28-0400
committerglittershark <grfn@gws.fyi>2020-07-23T04·28+0000
commitb1c0866037ea63b670055883de88a9fe4e8891e2 (patch)
treecef4735ba4745239d511cb6885cb538526f17471 /third_party/lisp/lass.nix
parentf591c32dfb2a9f0246c8d6501c1efab4c80da52f (diff)
feat(3p/lisp): Add LASS r/1423
Add LASS, a CSS library

Change-Id: I225959b12210895d0e5baf8a41ac09b0351f0aed
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1349
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'third_party/lisp/lass.nix')
-rw-r--r--third_party/lisp/lass.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/third_party/lisp/lass.nix b/third_party/lisp/lass.nix
new file mode 100644
index 0000000000..457e25c7e5
--- /dev/null
+++ b/third_party/lisp/lass.nix
@@ -0,0 +1,34 @@
+{ depot, pkgs, ... }:
+
+let
+  src = pkgs.fetchFromGitHub {
+    owner = "Shinmera";
+    repo = "LASS";
+    rev = "f51b9e941ee0a2a1f76ba814dcef22f9fb5f69bf";
+    sha256 = "11mxzyx34ynsfsrs8pgrarqi9s442vkpmh7kdpzvarhj7i97g8yx";
+  };
+
+in depot.nix.buildLisp.library {
+  name = "lass";
+
+  deps = with depot.third_party.lisp; [
+    trivial-indent
+    trivial-mimes
+    physical-quantities
+    parse-float
+    cl-base64
+    (depot.nix.buildLisp.bundled "asdf")
+  ];
+
+  srcs = map (f: src + ("/" + f)) [
+    "package.lisp"
+    "readable-list.lisp"
+    "compiler.lisp"
+    "property-funcs.lisp"
+    "writer.lisp"
+    "lass.lisp"
+    "special.lisp"
+    "units.lisp"
+    "asdf.lisp"
+  ];
+}