about summary refs log tree commit diff
path: root/third_party/lisp/fiveam.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-12-15T20·51+0300
committerclbot <clbot@tvl.fyi>2021-12-15T21·02+0000
commitfa73841a4b8bf305e375bdebf0c5b10b3fec4113 (patch)
tree702450de676048b2b2d13d306fe06c81c85dd070 /third_party/lisp/fiveam.nix
parent0784e68e204d93b7f447ef9e2f436cbc066920cc (diff)
chore(3p/lisp): use nixpkgs sources for fiveam r/3256
Change-Id: Id0613ace9b77d3ad46cdf2366e84d026d1158ace
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4340
Autosubmit: tazjin <mail@tazj.in>
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'third_party/lisp/fiveam.nix')
-rw-r--r--third_party/lisp/fiveam.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/third_party/lisp/fiveam.nix b/third_party/lisp/fiveam.nix
new file mode 100644
index 0000000000..500e980a81
--- /dev/null
+++ b/third_party/lisp/fiveam.nix
@@ -0,0 +1,29 @@
+# FiveAM is a Common Lisp testing framework.
+#
+# Imported from https://github.com/sionescu/fiveam.git
+
+{ depot, pkgs, ... }:
+
+let src = with pkgs; srcOnly lispPackages.fiveam;
+in depot.nix.buildLisp.library {
+  name = "fiveam";
+
+  deps = with depot.third_party.lisp; [
+    alexandria
+    asdf-flv
+    trivial-backtrace
+  ];
+
+  srcs = map (f: src + ("/src/" + f)) [
+    "package.lisp"
+    "utils.lisp"
+    "check.lisp"
+    "fixture.lisp"
+    "classes.lisp"
+    "random.lisp"
+    "test.lisp"
+    "explain.lisp"
+    "suite.lisp"
+    "run.lisp"
+  ];
+}