about summary refs log tree commit diff
path: root/third_party/lisp/drakma.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-12-14T21·32+0300
committertazjin <mail@tazj.in>2021-12-15T10·34+0000
commite9bfa84aafc65896e2fffead2f1ef4853bdd59af (patch)
tree711bd7c6aa289a7175c635c8866e75c85287ab45 /third_party/lisp/drakma.nix
parentb0614b5c83ae62672cb036bebb6ce12675aa3074 (diff)
refactor(3p/lisp): Use sources from nixpkgs where possible r/3246
nixpkgs includes a lispPackages set which is generated from something.
In the meantime, we pretty much never update our Lisp deps.

This commit ties our sources to nixpkgs.lispPackages where the desired
package is included in nixpkgs (which is actually most of them!)

Change-Id: I520a006535980271b2fa4e0ed4e34029475dcbef
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4331
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'third_party/lisp/drakma.nix')
-rw-r--r--third_party/lisp/drakma.nix7
1 files changed, 1 insertions, 6 deletions
diff --git a/third_party/lisp/drakma.nix b/third_party/lisp/drakma.nix
index 3757aad7b1..607f438d7e 100644
--- a/third_party/lisp/drakma.nix
+++ b/third_party/lisp/drakma.nix
@@ -1,12 +1,7 @@
 # Drakma is an HTTP client for Common Lisp.
 { depot, pkgs, ... }:
 
-let src = pkgs.fetchFromGitHub {
-  owner = "edicl";
-  repo = "drakma";
-  rev = "87feb02bef00b11a753d5fb21a5fec526b0d0bbb";
-  sha256 = "01b80am2vrw94xmdj7f21qm7p5ys08mmpzv4nc4icql81hqr1w2m";
-};
+let src = with pkgs; srcOnly lispPackages.drakma;
 in depot.nix.buildLisp.library {
   name = "drakma";
   deps = with depot.third_party.lisp; [