about summary refs log tree commit diff
path: root/third_party/lisp/drakma.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-10T00·13+0200
committertazjin <mail@tazj.in>2021-04-10T11·48+0000
commit8361b82d0ac59f436f7ecef283077b0f7d689ca1 (patch)
tree15f9649ae9f3381c7218ea4f46fc9979a12f11bd /third_party/lisp/drakma.nix
parent8d4b2f3d54e760ab9f7f8242370a54ff20796553 (diff)
refactor(third_party): Consistent use of depot.third_party vs. pkgs r/2461
In preparation for the solution of b/108, we need to consistently use
`depot.third_party` for packages that are only packed in the TVL depot
and `pkgs` for things that come from nixpkgs.

This commit cleans up a huge chunk of these uses in //third_party

Change-Id: Ic382c0cdea7330a84d5f0b7d109c824ddceb94e7
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2912
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'third_party/lisp/drakma.nix')
-rw-r--r--third_party/lisp/drakma.nix10
1 files changed, 4 insertions, 6 deletions
diff --git a/third_party/lisp/drakma.nix b/third_party/lisp/drakma.nix
index 8b8b9f1c90..80c82aee1f 100644
--- a/third_party/lisp/drakma.nix
+++ b/third_party/lisp/drakma.nix
@@ -1,15 +1,13 @@
 # Drakma is an HTTP client for Common Lisp.
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
-with depot.nix;
-
-let src = depot.third_party.fetchFromGitHub {
+let src = pkgs.fetchFromGitHub {
   owner = "edicl";
   repo = "drakma";
   rev = "87feb02bef00b11a753d5fb21a5fec526b0d0bbb";
   sha256 = "01b80am2vrw94xmdj7f21qm7p5ys08mmpzv4nc4icql81hqr1w2m";
 };
-in buildLisp.library {
+in depot.nix.buildLisp.library {
   name = "drakma";
   deps = with depot.third_party.lisp; [
     chipz
@@ -20,7 +18,7 @@ in buildLisp.library {
     flexi-streams
     puri
     usocket
-    (buildLisp.bundled "asdf")
+    (depot.nix.buildLisp.bundled "asdf")
   ];
 
   srcs = map (f: src + ("/" + f)) [