about summary refs log tree commit diff
path: root/third_party/lisp/defclass-std.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2021-04-11T22·17+0200
committersterni <sternenseemann@systemli.org>2021-04-12T14·00+0000
commit968effb5dc1a4617a0dceaffc70e986abe300c6e (patch)
tree84577ebd4eeeb27c7c02d7aa1ea658843489b244 /third_party/lisp/defclass-std.nix
parentf39b5a8a0dc94fd5226438791c1291e2f8186f91 (diff)
feat(3p): upgrade sbcl to 2.1.2 r/2484
sbcl 2.0.9 introduced a new warning:

> minor incompatible change: the compiler signals a warning at
> compile-time when an initform of T, NIL or 0 does not match
> a STANDARD-CLASS slot's declared type.

This broke a few packages, but they all have been fixed upstream in the
meantime and we only need to bump their versions. The culprits are:

* defclass-std which possibly has become unmaintained since the fix
  (december 2020).

* cl-prevalence which also needs one symbol from bt now

* lisp-binary which also includes a new file now

Change-Id: I06bb47a129d5ef912a623315c1281aedd1ceac2a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2934
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'third_party/lisp/defclass-std.nix')
-rw-r--r--third_party/lisp/defclass-std.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/third_party/lisp/defclass-std.nix b/third_party/lisp/defclass-std.nix
index 2573e46f53..781fd107f5 100644
--- a/third_party/lisp/defclass-std.nix
+++ b/third_party/lisp/defclass-std.nix
@@ -1,10 +1,12 @@
+# A shortcut macro to write DEFCLASS forms quickly
+# Seems to be unmaintained (since early 2021)
 { depot, pkgs, ... }:
 
 let src = pkgs.fetchFromGitHub {
     owner = "EuAndreh";
     repo = "defclass-std";
-    rev = "0300f171c1308e5ff3efd66b4f4e766f2bcde259";
-    sha256 = "0ggzh80ajx4k6w5c3xprnd7m27q5hx9xx9lxs4jv0pbrlg18ijcw";
+    rev = "a4d32260a619eddf3a3e49df3af304f3c07ccec6";
+    sha256 = "1c0ymb49wd205lzxmnmsrpqyv0pn61snn2xvsbk5iis135r4fr18";
   };
 in depot.nix.buildLisp.library {
   name = "defclass-std";