about summary refs log tree commit diff
path: root/third_party/lisp/closer-mop.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-10T00·13+0200
committertazjin <mail@tazj.in>2021-04-10T11·48+0000
commit8361b82d0ac59f436f7ecef283077b0f7d689ca1 (patch)
tree15f9649ae9f3381c7218ea4f46fc9979a12f11bd /third_party/lisp/closer-mop.nix
parent8d4b2f3d54e760ab9f7f8242370a54ff20796553 (diff)
refactor(third_party): Consistent use of depot.third_party vs. pkgs r/2461
In preparation for the solution of b/108, we need to consistently use
`depot.third_party` for packages that are only packed in the TVL depot
and `pkgs` for things that come from nixpkgs.

This commit cleans up a huge chunk of these uses in //third_party

Change-Id: Ic382c0cdea7330a84d5f0b7d109c824ddceb94e7
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2912
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'third_party/lisp/closer-mop.nix')
-rw-r--r--third_party/lisp/closer-mop.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/third_party/lisp/closer-mop.nix b/third_party/lisp/closer-mop.nix
index ab7e33e59b..0fda09bbb4 100644
--- a/third_party/lisp/closer-mop.nix
+++ b/third_party/lisp/closer-mop.nix
@@ -1,9 +1,9 @@
 # Closer to MOP is a compatibility layer that rectifies many of the
 # absent or incorrect CLOS MOP features across a broad range of Common
 # Lisp implementations
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
-let src = depot.third_party.fetchFromGitHub {
+let src = pkgs.fetchFromGitHub {
   owner = "pcostanza";
   repo = "closer-mop";
   rev = "e1d1430524086709a7ea8e0eede6849aa29d6276";