about summary refs log tree commit diff
path: root/third_party/lisp/cl-prevalence.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2021-04-11T22·17+0200
committersterni <sternenseemann@systemli.org>2021-04-12T14·00+0000
commit968effb5dc1a4617a0dceaffc70e986abe300c6e (patch)
tree84577ebd4eeeb27c7c02d7aa1ea658843489b244 /third_party/lisp/cl-prevalence.nix
parentf39b5a8a0dc94fd5226438791c1291e2f8186f91 (diff)
feat(3p): upgrade sbcl to 2.1.2 r/2484
sbcl 2.0.9 introduced a new warning:

> minor incompatible change: the compiler signals a warning at
> compile-time when an initform of T, NIL or 0 does not match
> a STANDARD-CLASS slot's declared type.

This broke a few packages, but they all have been fixed upstream in the
meantime and we only need to bump their versions. The culprits are:

* defclass-std which possibly has become unmaintained since the fix
  (december 2020).

* cl-prevalence which also needs one symbol from bt now

* lisp-binary which also includes a new file now

Change-Id: I06bb47a129d5ef912a623315c1281aedd1ceac2a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2934
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'third_party/lisp/cl-prevalence.nix')
-rw-r--r--third_party/lisp/cl-prevalence.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/third_party/lisp/cl-prevalence.nix b/third_party/lisp/cl-prevalence.nix
index 5c4a65f02d..f793136194 100644
--- a/third_party/lisp/cl-prevalence.nix
+++ b/third_party/lisp/cl-prevalence.nix
@@ -5,13 +5,14 @@
 let src = pkgs.fetchFromGitHub {
   owner = "40ants";
   repo = "cl-prevalence";
-  rev = "da3ed6c4594b1c2fca90c178c1993973c4bf16c9";
-  sha256 = "0bq905hv1626dl6b7s0zn4lbdh608g1pxaljl1fda6pwp9hmj95a";
+  rev = "b1f90a525f37be0335a8761051fa5661aa74b696";
+  sha256 = "1svw58pp7jxb9l08cgnqxf0cf8qa9qsb0z2fnv86a51z7pfz4c0g";
 };
 in depot.nix.buildLisp.library {
   name = "cl-prevalence";
 
   deps = with depot.third_party.lisp; [
+    bordeaux-threads
     s-xml
     s-sysdeps
   ];