about summary refs log tree commit diff
path: root/third_party/lisp/cl-ppcre.nix
diff options
context:
space:
mode:
authorAspen Smith <root@gws.fyi>2024-03-23T14·20-0400
committerclbot <clbot@tvl.fyi>2024-03-31T19·18+0000
commitd5f57ac6e68f3acd79f1abc91d8ee9afc435018f (patch)
tree8e96aaf920b4c46d705137485d673adb74ffc4a7 /third_party/lisp/cl-ppcre.nix
parent87d5dd6371632edc9027a3e75ec6e1afc5b9d825 (diff)
feat(3p/lisp): Add str package and dependencies r/7825
Change-Id: Iffb66f4580517b1dbfee8c79e766552508695e5f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11252
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Autosubmit: aspen <root@gws.fyi>
Diffstat (limited to 'third_party/lisp/cl-ppcre.nix')
-rw-r--r--third_party/lisp/cl-ppcre.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/third_party/lisp/cl-ppcre.nix b/third_party/lisp/cl-ppcre.nix
index 561e306191ca..7cb99db639fd 100644
--- a/third_party/lisp/cl-ppcre.nix
+++ b/third_party/lisp/cl-ppcre.nix
@@ -24,4 +24,16 @@ in depot.nix.buildLisp.library {
     "scanner.lisp"
     "api.lisp"
   ];
+
+  passthru = {
+    unicode = depot.nix.buildLisp.library {
+      name = "cl-ppcre-unicode";
+      deps = with depot.third_party.lisp; [ cl-ppcre cl-unicode ];
+
+      srcs = map (f: src + ("/cl-ppcre-unicode/" + f)) [
+        "packages.lisp"
+        "resolver.lisp"
+      ];
+    };
+  };
 }