about summary refs log tree commit diff
path: root/third_party/lisp/cl-plus-ssl.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-02-21T12·47+0000
committerVincent Ambo <tazjin@google.com>2020-02-21T13·54+0000
commit4bbbb58cb537014dd8b0b3c3c560c039ac57ad89 (patch)
treeffd6c2c6758f655801ea6497b3dd9d2f2d04ebc9 /third_party/lisp/cl-plus-ssl.nix
parent5d9d84f4cfdbed049e71ce6f15bb1ad8650f7acf (diff)
chore: Rename pkgs->depot in all Nix file headers r/559
Diffstat (limited to 'third_party/lisp/cl-plus-ssl.nix')
-rw-r--r--third_party/lisp/cl-plus-ssl.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/third_party/lisp/cl-plus-ssl.nix b/third_party/lisp/cl-plus-ssl.nix
index 1e725ba00a..63c21aa6ba 100644
--- a/third_party/lisp/cl-plus-ssl.nix
+++ b/third_party/lisp/cl-plus-ssl.nix
@@ -1,7 +1,7 @@
 # Common Lisp bindings to OpenSSL
-{ pkgs, ... }:
+{ depot, ... }:
 
-with pkgs.nix;
+with depot.nix;
 
 let src = builtins.fetchGit {
   url = "https://github.com/cl-plus-ssl/cl-plus-ssl.git";
@@ -9,7 +9,7 @@ let src = builtins.fetchGit {
 };
 in buildLisp.library {
   name = "cl-plus-ssl";
-  deps = with pkgs.third_party.lisp; [
+  deps = with depot.third_party.lisp; [
     alexandria
     bordeaux-threads
     cffi
@@ -21,7 +21,7 @@ in buildLisp.library {
     (buildLisp.bundled "sb-posix")
   ];
 
-  native = [ pkgs.third_party.openssl ];
+  native = [ depot.third_party.openssl ];
 
   srcs = map (f: src + ("/src/" + f)) [
     "package.lisp"