about summary refs log tree commit diff
path: root/third_party/lisp/cl-fad.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-01-22T00·23+0000
committerVincent Ambo <tazjin@google.com>2020-01-22T00·23+0000
commitfe3ea06cbc32c9b727549a6505e69234f3072f6f (patch)
tree0fca475404528540bcf1bef98f9360ba67c828a2 /third_party/lisp/cl-fad.nix
parent6de462f674affc4407b89ffe356c2159efad353c (diff)
feat(third_party/lisp): Add derivations for hunchentoot & deps r/437
Diffstat (limited to 'third_party/lisp/cl-fad.nix')
-rw-r--r--third_party/lisp/cl-fad.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/third_party/lisp/cl-fad.nix b/third_party/lisp/cl-fad.nix
new file mode 100644
index 0000000000..474e4b6963
--- /dev/null
+++ b/third_party/lisp/cl-fad.nix
@@ -0,0 +1,25 @@
+# Portable pathname library
+{ pkgs, ...}:
+
+let src = pkgs.third_party.fetchFromGitHub {
+  owner = "edicl";
+  repo = "cl-fad";
+  rev = "c13d81c4bd9ba3a172631fd05dd213ab90e7d4cb";
+  sha256 = "1gc8i82v6gks7g0lnm54r4prk2mklidv2flm5fvbr0a7rsys0vpa";
+};
+in pkgs.nix.buildLisp.library {
+  name = "cl-fad";
+
+  deps = with pkgs.third_party.lisp; [
+    alexandria
+    bordeaux-threads
+    sb-posix
+  ];
+
+  srcs = map (f: src + ("/" + f)) [
+    "packages.lisp"
+    "fad.lisp"
+    "path.lisp"
+    "temporary-files.lisp"
+  ];
+}