about summary refs log tree commit diff
path: root/third_party/lisp/cl-fad.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-01-26T23·59+0000
committerVincent Ambo <tazjin@google.com>2020-01-26T23·59+0000
commita41b8c70a68b3b6d848d708cd8058866b23847e6 (patch)
tree18cf49e0e1adce9c780e45909c7e14de4063b27a /third_party/lisp/cl-fad.nix
parentca60eafa808e2423fd64996b4f678b08ed3277a5 (diff)
refactor(third_party/lisp): Use buildLisp.bundled for built-in libs r/462
Deprecates derivations for:

* sb-bsd-sockets
* sb-posix
* sb-rotate-byte
* uiop
Diffstat (limited to 'third_party/lisp/cl-fad.nix')
-rw-r--r--third_party/lisp/cl-fad.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/third_party/lisp/cl-fad.nix b/third_party/lisp/cl-fad.nix
index 474e4b6963..194ecd3956 100644
--- a/third_party/lisp/cl-fad.nix
+++ b/third_party/lisp/cl-fad.nix
@@ -1,19 +1,21 @@
 # Portable pathname library
 { pkgs, ...}:
 
+with pkgs.nix;
+
 let src = pkgs.third_party.fetchFromGitHub {
   owner = "edicl";
   repo = "cl-fad";
   rev = "c13d81c4bd9ba3a172631fd05dd213ab90e7d4cb";
   sha256 = "1gc8i82v6gks7g0lnm54r4prk2mklidv2flm5fvbr0a7rsys0vpa";
 };
-in pkgs.nix.buildLisp.library {
+in buildLisp.library {
   name = "cl-fad";
 
   deps = with pkgs.third_party.lisp; [
     alexandria
     bordeaux-threads
-    sb-posix
+    (buildLisp.bundled "sb-posix")
   ];
 
   srcs = map (f: src + ("/" + f)) [