about summary refs log tree commit diff
path: root/third_party/lisp/cl-change-case.nix
diff options
context:
space:
mode:
authorAspen Smith <root@gws.fyi>2024-03-23T14·20-0400
committerclbot <clbot@tvl.fyi>2024-03-31T19·18+0000
commitd5f57ac6e68f3acd79f1abc91d8ee9afc435018f (patch)
tree8e96aaf920b4c46d705137485d673adb74ffc4a7 /third_party/lisp/cl-change-case.nix
parent87d5dd6371632edc9027a3e75ec6e1afc5b9d825 (diff)
feat(3p/lisp): Add str package and dependencies r/7825
Change-Id: Iffb66f4580517b1dbfee8c79e766552508695e5f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11252
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Autosubmit: aspen <root@gws.fyi>
Diffstat (limited to 'third_party/lisp/cl-change-case.nix')
-rw-r--r--third_party/lisp/cl-change-case.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/third_party/lisp/cl-change-case.nix b/third_party/lisp/cl-change-case.nix
new file mode 100644
index 000000000000..b66368a9b6e3
--- /dev/null
+++ b/third_party/lisp/cl-change-case.nix
@@ -0,0 +1,22 @@
+{ depot, pkgs, ... }:
+
+let src = with pkgs; srcOnly lispPackages.cl-change-case;
+in depot.nix.buildLisp.library {
+  name = "cl-change-case";
+
+  deps = with depot.third_party.lisp; [ cl-ppcre cl-ppcre.unicode ];
+
+  srcs = [ (src + "/src/cl-change-case.lisp") ];
+
+  tests = {
+    name = "cl-change-case-tests";
+    srcs = [ (src + "/t/cl-change-case.lisp") ];
+    deps = [
+      depot.third_party.lisp.fiveam
+    ];
+
+    expression = ''
+      (5am:run! :cl-change-case)
+    '';
+  };
+}