about summary refs log tree commit diff
path: root/third_party/lisp/cl-arrows.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-01-23T21·56+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-01-23T21·57+0000
commit2e3bb0435f2849e2a5d4da0ed8408c2993ca9052 (patch)
tree4ff9517891fcd6d8437b32aa455264ab2b0f8cc5 /third_party/lisp/cl-arrows.nix
parent81d7bc405eaf631bf58377c629af6d461021bb67 (diff)
Package cl-arrows package
Using Nix to package this library of Clojure-inspired threading macros.

TODO: Send this patch to tazjin.
Diffstat (limited to 'third_party/lisp/cl-arrows.nix')
-rw-r--r--third_party/lisp/cl-arrows.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/third_party/lisp/cl-arrows.nix b/third_party/lisp/cl-arrows.nix
new file mode 100644
index 000000000000..60cd8a375b1c
--- /dev/null
+++ b/third_party/lisp/cl-arrows.nix
@@ -0,0 +1,15 @@
+{ depot ? import <depot> {}, ... }:
+
+let
+  src = builtins.fetchGit {
+    url = "https://github.com/nightfly19/cl-arrows.git";
+    rev = "cbb46b69a7de40f1161c9caaf6cef93b3af9994f";
+  };
+in depot.nix.buildLisp.library {
+  name = "cl-arrows";
+  deps = [];
+  srcs = [
+    "${src}/packages.lisp"
+    "${src}/arrows.lisp"
+  ];
+}