about summary refs log tree commit diff
path: root/third_party/lisp/cl-arrows.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-12-14T21·00+0300
committerclbot <clbot@tvl.fyi>2021-12-14T21·21+0000
commitb0614b5c83ae62672cb036bebb6ce12675aa3074 (patch)
treeac2a4fafa87dae3a0f452fb54977421db9a21344 /third_party/lisp/cl-arrows.nix
parent46a2c75a596b292d02d8647dfb44205dd876fd6f (diff)
refactor(3p/lisp): Move things from //users/wpcarro/third_party/lisp r/3245
* move packages and adapt them for the depot structure instead of
  briefcase
* drop linear-programming package, it didn't build anyways

Note that at least some of these packages (e.g. prove) are deprecated
upstream, but lets sort that out later.

Change-Id: I7f5a5faa29d57f060b21ac8e1706090866a82000
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4330
Autosubmit: tazjin <mail@tazj.in>
Reviewed-by: grfn <grfn@gws.fyi>
Reviewed-by: wpcarro <wpcarro@gmail.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'third_party/lisp/cl-arrows.nix')
-rw-r--r--third_party/lisp/cl-arrows.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/third_party/lisp/cl-arrows.nix b/third_party/lisp/cl-arrows.nix
new file mode 100644
index 000000000000..778adbf69c66
--- /dev/null
+++ b/third_party/lisp/cl-arrows.nix
@@ -0,0 +1,16 @@
+{ depot, pkgs, ... }:
+
+let
+  src = pkgs.fetchgit {
+    url = "https://github.com/nightfly19/cl-arrows.git";
+    rev = "cbb46b69a7de40f1161c9caaf6cef93b3af9994f";
+    hash = "sha256:0la2vr10510vmx29w9p3sj1qi1sych0crcpy4kdgxzn8m7kqlli0";
+  };
+in depot.nix.buildLisp.library {
+  name = "cl-arrows";
+  deps = [];
+  srcs = [
+    "${src}/packages.lisp"
+    "${src}/arrows.lisp"
+  ];
+}