about summary refs log tree commit diff
path: root/third_party/lisp/chunga.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-01-21T02·06+0000
committerVincent Ambo <tazjin@google.com>2020-01-21T02·07+0000
commit6de462f674affc4407b89ffe356c2159efad353c (patch)
treefebc9f4d76a3ff5c9d9e74a90fb3504836609f39 /third_party/lisp/chunga.nix
parente50c669310811d45f1d89b50c359e9b1adbce21d (diff)
feat(third_party/lisp): Check in drakma HTTP client & deps r/436
This HTTP client has much fewer dependencies than some of the other
ones I've seen, and it'll be good enough for my demo purposes.
Diffstat (limited to 'third_party/lisp/chunga.nix')
-rw-r--r--third_party/lisp/chunga.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/third_party/lisp/chunga.nix b/third_party/lisp/chunga.nix
new file mode 100644
index 0000000000..b56fb3b90c
--- /dev/null
+++ b/third_party/lisp/chunga.nix
@@ -0,0 +1,27 @@
+# Portable chunked streams for Common Lisp
+{ pkgs, ... }:
+
+let src = pkgs.third_party.fetchFromGitHub {
+  owner = "edicl";
+  repo = "chunga";
+  rev = "16330852d01dfde4dd97dee7cd985a88ea571e7e";
+  sha256 = "0jzn3nyb3f22gm983rfk99smqs3mhb9ivjmasvhq9qla5cl9pyhd";
+};
+in pkgs.nix.buildLisp.library {
+  name = "chunga";
+  deps = with pkgs.third_party.lisp; [
+    trivial-gray-streams
+  ];
+
+  srcs = map (f: src + ("/" + f)) [
+    "packages.lisp"
+    "specials.lisp"
+    "util.lisp"
+    "known-words.lisp"
+    "conditions.lisp"
+    "read.lisp"
+    "streams.lisp"
+    "input.lisp"
+    "output.lisp"
+  ];
+}