about summary refs log tree commit diff
path: root/third_party/lisp/bordeaux-threads.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-12-14T21·32+0300
committertazjin <mail@tazj.in>2021-12-15T10·34+0000
commite9bfa84aafc65896e2fffead2f1ef4853bdd59af (patch)
tree711bd7c6aa289a7175c635c8866e75c85287ab45 /third_party/lisp/bordeaux-threads.nix
parentb0614b5c83ae62672cb036bebb6ce12675aa3074 (diff)
refactor(3p/lisp): Use sources from nixpkgs where possible r/3246
nixpkgs includes a lispPackages set which is generated from something.
In the meantime, we pretty much never update our Lisp deps.

This commit ties our sources to nixpkgs.lispPackages where the desired
package is included in nixpkgs (which is actually most of them!)

Change-Id: I520a006535980271b2fa4e0ed4e34029475dcbef
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4331
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'third_party/lisp/bordeaux-threads.nix')
-rw-r--r--third_party/lisp/bordeaux-threads.nix7
1 files changed, 2 insertions, 5 deletions
diff --git a/third_party/lisp/bordeaux-threads.nix b/third_party/lisp/bordeaux-threads.nix
index 92bc1f2629..17ee6e539e 100644
--- a/third_party/lisp/bordeaux-threads.nix
+++ b/third_party/lisp/bordeaux-threads.nix
@@ -1,12 +1,9 @@
 # This library is meant to make writing portable multi-threaded apps
 # in Common Lisp simple.
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
 let
-  src = builtins.fetchGit {
-    url = "https://github.com/sionescu/bordeaux-threads.git";
-    rev = "499b6d3f0ce635417d6096acf0a671d8bf3f6e5f";
-  };
+  src = with pkgs; srcOnly lispPackages.bordeaux-threads;
   getSrc = f: "${src}/src/${f}";
 in depot.nix.buildLisp.library {
   name = "bordeaux-threads";