about summary refs log tree commit diff
path: root/third_party/lisp/babel.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-12-14T21·32+0300
committertazjin <mail@tazj.in>2021-12-15T10·34+0000
commite9bfa84aafc65896e2fffead2f1ef4853bdd59af (patch)
tree711bd7c6aa289a7175c635c8866e75c85287ab45 /third_party/lisp/babel.nix
parentb0614b5c83ae62672cb036bebb6ce12675aa3074 (diff)
refactor(3p/lisp): Use sources from nixpkgs where possible r/3246
nixpkgs includes a lispPackages set which is generated from something.
In the meantime, we pretty much never update our Lisp deps.

This commit ties our sources to nixpkgs.lispPackages where the desired
package is included in nixpkgs (which is actually most of them!)

Change-Id: I520a006535980271b2fa4e0ed4e34029475dcbef
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4331
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'third_party/lisp/babel.nix')
-rw-r--r--third_party/lisp/babel.nix7
1 files changed, 2 insertions, 5 deletions
diff --git a/third_party/lisp/babel.nix b/third_party/lisp/babel.nix
index c4a49e833f..ae7c5dd23d 100644
--- a/third_party/lisp/babel.nix
+++ b/third_party/lisp/babel.nix
@@ -1,10 +1,7 @@
 # Babel is an encoding conversion library for Common Lisp.
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
-let src = builtins.fetchGit {
-  url = "https://github.com/cl-babel/babel.git";
-  rev = "f892d0587c7f3a1e6c0899425921b48008c29ee3"; # 2020-07-19
-};
+let src = with pkgs; srcOnly lispPackages.babel;
 in depot.nix.buildLisp.library {
   name = "babel";
   deps = [