about summary refs log tree commit diff
path: root/third_party/lisp/anaphora.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-01-23T16·31+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-01-23T16·31+0000
commite76843d337546fe83dbbc9eba9cff52ca6767ef7 (patch)
treed84c362758d6926715ef597d5501e14918549974 /third_party/lisp/anaphora.nix
parent393bd0a5c7967c9eafbf228413416d7691125e59 (diff)
Create third_party
Create a third_party subdirectory and a third_party/lisp. This directory layout
resembles and is inspired by the layout of Google's mono-repo, Google3. @tazjin
borrowed this idea from Google and I'm borrowing the idea from him.
Diffstat (limited to 'third_party/lisp/anaphora.nix')
-rw-r--r--third_party/lisp/anaphora.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/third_party/lisp/anaphora.nix b/third_party/lisp/anaphora.nix
new file mode 100644
index 000000000000..04a1dd847feb
--- /dev/null
+++ b/third_party/lisp/anaphora.nix
@@ -0,0 +1,17 @@
+{ depot ? import <depot> {}, ... }:
+
+let
+  src = builtins.fetchGit {
+    url = "https://github.com/tokenrove/anaphora.git";
+    rev = "aeace4c68cf55098a67112750b28f8f2dc6d0e30";
+  };
+in depot.nix.buildLisp.library {
+  name = "anaphora";
+  deps = [];
+  srcs = [
+    "${src}/packages.lisp"
+    "${src}/early.lisp"
+    "${src}/symbolic.lisp"
+    "${src}/anaphora.lisp"
+  ];
+}