about summary refs log tree commit diff
path: root/third_party/lieer/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-05-22T19·38+0200
committertazjin <mail@tazj.in>2021-05-22T20·58+0000
commit4a807040a2607ccaa8c992f707ff085cd3bab5ca (patch)
tree47468b12cc5d8d2c3ba5c023aa72ebf32decca7e /third_party/lieer/default.nix
parent687f978b1c2b37f3a835f059181ee41ce44db539 (diff)
refactor(tazjin/emacs): Switch to sending mail via lieer r/2607
This drops the msmtp requirement from my configuration; there's still
some cleanup to be done but I need to double-check this in a few
environments first.

Change-Id: I298f4ff77b45cb214fbccee84e9bbd861508d11a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3132
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'third_party/lieer/default.nix')
-rw-r--r--third_party/lieer/default.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/third_party/lieer/default.nix b/third_party/lieer/default.nix
deleted file mode 100644
index 8bd2916c40..0000000000
--- a/third_party/lieer/default.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-# Lieer is a small tool to synchronise a Gmail account with a local
-# maildir.
-{ pkgs, ... }:
-
-let
-  inherit (pkgs) fetchFromGitHub python3Packages;
-in python3Packages.buildPythonApplication rec {
-  name = "lieer-${version}";
-  version = "1.3";
-
-  src = fetchFromGitHub {
-    owner = "gauteh";
-    repo = "lieer";
-    rev = "v${version}";
-    sha256 = "12sl7d381l1gjaam419xc8gxmsprxf0hgksz1f974qmmijvr02bh";
-  };
-
-  patches = [
-    ./send_scope.patch
-  ];
-
-  propagatedBuildInputs = with python3Packages; [
-    notmuch
-    oauth2client
-    google-api-python-client
-    tqdm
-  ];
-}