about summary refs log tree commit diff
path: root/third_party/lieer/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-25T13·09+0100
committerVincent Ambo <tazjin@google.com>2019-12-25T13·09+0100
commit3c94625a5fa352ccc73a82f554346ad00a176f25 (patch)
treea4eced5a7fda4b88dee04b4a6879742ec961b191 /third_party/lieer/default.nix
parent4a0cf0de9879f016490fee6e4b3b8197d54be29c (diff)
chore(lieer): Remove OAuth client patch r/300
This is now done in my work-specific configuration, which is
elsewhere.
Diffstat (limited to '')
-rw-r--r--third_party/lieer/default.nix15
1 files changed, 1 insertions, 14 deletions
diff --git a/third_party/lieer/default.nix b/third_party/lieer/default.nix
index 810a3df1a5..80bd063501 100644
--- a/third_party/lieer/default.nix
+++ b/third_party/lieer/default.nix
@@ -7,18 +7,7 @@
 
 with pkgs.third_party;
 
-let
-  # My employer does not allow third-party projects to use our email
-  # accounts, but I want to use lieer for it anyways.
-  #
-  # To accomplish this the following derivation creates a patch that
-  # replaces the API client with one that I control.
-  authPatch = runCommand "client_secret.patch" {} ''
-    export PATH=${lib.makeBinPath [ gettext ]}:$PATH
-    export CLIENT_SECRET='${builtins.getEnv "LIEER_CLIENT_SECRET"}'
-    cat ${./api_client.patch} | envsubst > $out
-  '';
-in python3Packages.buildPythonApplication rec {
+python3Packages.buildPythonApplication rec {
   name = "lieer-${version}";
   version = "1.0";
 
@@ -29,8 +18,6 @@ in python3Packages.buildPythonApplication rec {
     sha256 = "1zzylv8xbcrh34bz0s29dawzcyx39lai8y8wk0bl4x75v1jfynvf";
   };
 
-  patches = [ authPatch ];
-
   propagatedBuildInputs = with python3Packages; [
     notmuch
     oauth2client