about summary refs log tree commit diff
path: root/third_party/josh/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-06-01T21·34+0200
committertazjin <mail@tazj.in>2021-06-02T08·00+0000
commite0708cba8d8b95f961534bdd2d605cdda78dbb6c (patch)
tree9125a590659db59c011aec36fbc6e392191ff4d1 /third_party/josh/default.nix
parent00d2af6d7e36234d7cf27cff1a7da8b9c1aaf175 (diff)
fix(3p/josh): Temporarily patch instances of master->canon r/2641
... until hardcoded references are removed upstream.

This is motivated by HEAD-branch related issues when cloning depot via
josh and a naive search for places where `master` was used directly.

Change-Id: I46709631d6ee5561344fc5f407324bcf69c641e2
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3171
Tested-by: BuildkiteCI
Reviewed-by: cschilling <christian.schilling.de@gmail.com>
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to '')
-rw-r--r--third_party/josh/default.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/third_party/josh/default.nix b/third_party/josh/default.nix
index 2b6cff582c..6c49809b51 100644
--- a/third_party/josh/default.nix
+++ b/third_party/josh/default.nix
@@ -22,4 +22,8 @@ in depot.third_party.naersk.buildPackage {
     "-p" "josh-proxy"
     "-p" "josh-ui"
   ];
+
+  overrideMain = x: {
+    patches = [ ./0001-replace-mentions-of-master-with-canon.patch ];
+  };
 }