about summary refs log tree commit diff
path: root/third_party/immer/test/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-07-15T07·20+0100
committerVincent Ambo <mail@tazj.in>2020-07-15T07·23+0100
commit1213b086a1015a662ab7ebd658f784534fd3116a (patch)
treed3bc8f3b7f40b8b60f0ef6fbd649cf765f4fdfb6 /third_party/immer/test/CMakeLists.txt
parent1390827b9ea1e04bc9863e48930bfd16db3b716e (diff)
parent7f19d641647ac4ef313ed88d6b5c140983ce5436 (diff)
merge(3p/immer): Subtree merge at 'ad3e3556d' as 'third_party/immer' r/1299
Change-Id: I9636a41ad44b4218293833fd3e9456d9b07c731b
Diffstat (limited to 'third_party/immer/test/CMakeLists.txt')
-rw-r--r--third_party/immer/test/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/third_party/immer/test/CMakeLists.txt b/third_party/immer/test/CMakeLists.txt
new file mode 100644
index 0000000000..faa61bbe6d
--- /dev/null
+++ b/third_party/immer/test/CMakeLists.txt
@@ -0,0 +1,22 @@
+
+#  Targets
+#  =======
+
+add_custom_target(tests
+  COMMENT "Build all the unit tests.")
+add_dependencies(check tests)
+
+include(CTest)
+
+file(GLOB_RECURSE immer_unit_tests "*.cpp")
+foreach(_file IN LISTS immer_unit_tests)
+  immer_target_name_for(_target _output "${_file}")
+  add_executable(${_target} EXCLUDE_FROM_ALL "${_file}")
+  set_target_properties(${_target} PROPERTIES OUTPUT_NAME ${_output})
+  add_dependencies(tests ${_target})
+  target_compile_definitions(${_target} PUBLIC
+    DOCTEST_CONFIG_IMPLEMENT_WITH_MAIN
+    CATCH_CONFIG_MAIN)
+  target_link_libraries(${_target} PUBLIC immer-dev)
+  add_test("test/${_output}" ${_output})
+endforeach()