about summary refs log tree commit diff
path: root/third_party/immer/extra/python/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-12-23T12·36+0100
committertazjin <mail@tazj.in>2020-12-23T12·44+0000
commit73e9265f954528b6b2eccf98572e77126539a8df (patch)
tree48a1e093761e86c5e605d074e8c4d5f1bb64f1b1 /third_party/immer/extra/python/CMakeLists.txt
parentf7ea650142eb796eb3f2827c805cc0bc563e2183 (diff)
chore(3p/immer): Remove vendored copy of immer r/2029
We ended up dropping the use of this library again.

Change-Id: I2c44cd22a6128d23f87a582402bf5fb84991d608
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2292
Tested-by: BuildkiteCI
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'third_party/immer/extra/python/CMakeLists.txt')
-rw-r--r--third_party/immer/extra/python/CMakeLists.txt46
1 files changed, 0 insertions, 46 deletions
diff --git a/third_party/immer/extra/python/CMakeLists.txt b/third_party/immer/extra/python/CMakeLists.txt
deleted file mode 100644
index 11d5fff209ad..000000000000
--- a/third_party/immer/extra/python/CMakeLists.txt
+++ /dev/null
@@ -1,46 +0,0 @@
-
-option(USE_PYBIND "bind with pybind1" off)
-option(USE_BOOST_PYTHON  "bind with boost::python" off)
-
-if (USE_PYBIND)
-  set(PYBIND11_CPP_STANDARD -std=c++14)
-  find_package(Boost 1.56 REQUIRED)
-  add_subdirectory(lib/pybind11)
-  pybind11_add_module(immer_python_module src/immer-pybind.cpp)
-  target_link_libraries(immer_python_module PUBLIC
-    immer)
-
-elseif(USE_BOOST_PYTHON)
-  find_package(PythonInterp)
-  find_package(PythonLibs)
-  find_package(Boost 1.56 COMPONENTS python)
-  python_add_module(immer_python_module src/immer-boost.cpp)
-  include_directories(immer_python_module PUBLIC
-    ${immer_include_dir}
-    ${Boost_INCLUDE_DIRS}
-    ${PYTHON_INCLUDE_DIRS})
-  target_link_libraries(immer_python_module PUBLIC
-    immer
-    ${Boost_LIBRARIES}
-    ${PYTHON_LIBRARIES})
-
-else()
-  find_package(PythonInterp)
-  find_package(PythonLibs)
-
-  if (NOT PYTHONLIBS_FOUND)
-    message(STATUS "Disabling Python modules")
-    return()
-  endif()
-
-  python_add_module(immer_python_module EXCLUDE_FROM_ALL
-    src/immer-raw.cpp)
-  target_include_directories(immer_python_module PUBLIC
-    ${PYTHON_INCLUDE_DIRS})
-  target_link_libraries(immer_python_module PUBLIC
-    immer
-    ${PYTHON_LIBRARIES})
-
-endif()
-
-add_custom_target(python DEPENDS immer_python_module)