about summary refs log tree commit diff
path: root/third_party/immer/example/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-12-23T12·36+0100
committertazjin <mail@tazj.in>2020-12-23T12·44+0000
commit73e9265f954528b6b2eccf98572e77126539a8df (patch)
tree48a1e093761e86c5e605d074e8c4d5f1bb64f1b1 /third_party/immer/example/CMakeLists.txt
parentf7ea650142eb796eb3f2827c805cc0bc563e2183 (diff)
chore(3p/immer): Remove vendored copy of immer r/2029
We ended up dropping the use of this library again.

Change-Id: I2c44cd22a6128d23f87a582402bf5fb84991d608
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2292
Tested-by: BuildkiteCI
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'third_party/immer/example/CMakeLists.txt')
-rw-r--r--third_party/immer/example/CMakeLists.txt17
1 files changed, 0 insertions, 17 deletions
diff --git a/third_party/immer/example/CMakeLists.txt b/third_party/immer/example/CMakeLists.txt
deleted file mode 100644
index 2aa0f554279d..000000000000
--- a/third_party/immer/example/CMakeLists.txt
+++ /dev/null
@@ -1,17 +0,0 @@
-
-#  Targets
-#  =======
-
-add_custom_target(examples
-  COMMENT "Build all examples.")
-add_dependencies(check examples)
-
-file(GLOB_RECURSE immer_examples "*.cpp")
-foreach(_file IN LISTS immer_examples)
-  immer_target_name_for(_target _output "${_file}")
-  add_executable(${_target} EXCLUDE_FROM_ALL "${_file}")
-  add_dependencies(examples ${_target})
-  set_target_properties(${_target} PROPERTIES OUTPUT_NAME ${_output})
-  target_link_libraries(${_target} PUBLIC immer-dev)
-  add_test("example/${_output}" ${_output})
-endforeach()