about summary refs log tree commit diff
path: root/third_party/gopkgs/google.golang.org
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-11-21T21·09+0300
committertazjin <tazjin@tvl.su>2022-01-17T14·18+0000
commit1c81ccb99634d107eb7f9b986bc4822c7a517d13 (patch)
treed481efeed953557bb5611c957133194980354251 /third_party/gopkgs/google.golang.org
parent1d281151dedcfe1795e03755a1cf22b08d96cd30 (diff)
fix(3p): Move away from builtins.fetchGit r/3619
Moves to the derivation-based git fetchers everywhere in third-party.
This might help with forward-compatibility with newer Nix versions,
though that's not our primary concern right now.

Change-Id: I565bb72585b8639893e9ea3a9e233338aede63a9
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3903
Tested-by: BuildkiteCI
Reviewed-by: zseri <zseri.devel@ytrizja.de>
Diffstat (limited to 'third_party/gopkgs/google.golang.org')
-rw-r--r--third_party/gopkgs/google.golang.org/api/default.nix6
-rw-r--r--third_party/gopkgs/google.golang.org/genproto/default.nix6
-rw-r--r--third_party/gopkgs/google.golang.org/grpc/default.nix6
3 files changed, 12 insertions, 6 deletions
diff --git a/third_party/gopkgs/google.golang.org/api/default.nix b/third_party/gopkgs/google.golang.org/api/default.nix
index 0d2f173e30..490d3a9d2b 100644
--- a/third_party/gopkgs/google.golang.org/api/default.nix
+++ b/third_party/gopkgs/google.golang.org/api/default.nix
@@ -1,10 +1,12 @@
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
 depot.nix.buildGo.external {
   path = "google.golang.org/api";
-  src = builtins.fetchGit {
+
+  src = pkgs.fetchgit {
     url = "https://code.googlesource.com/google-api-go-client";
     rev = "8b4e46d953bd748a9ff098644a42389b3d8dab41";
+    hash = "sha256:1vffav53qkksrhdqnp8013v90ks6d7jra0vh3sbybg0v0bka7n3p";
   };
 
   deps = with depot.third_party; [
diff --git a/third_party/gopkgs/google.golang.org/genproto/default.nix b/third_party/gopkgs/google.golang.org/genproto/default.nix
index fa25d13607..cba54e5890 100644
--- a/third_party/gopkgs/google.golang.org/genproto/default.nix
+++ b/third_party/gopkgs/google.golang.org/genproto/default.nix
@@ -1,10 +1,12 @@
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
 depot.nix.buildGo.external {
   path = "google.golang.org/genproto";
-  src = builtins.fetchGit {
+
+  src = pkgs.fetchgit {
     url = "https://github.com/google/go-genproto";
     rev = "0243a4be9c8f1264d238fdc2895620b4d9baf9e1";
+    hash = "sha256:071672lk0pzns98ncbqk6np7l9flwh84hjjibhhm2s1fi941m6q3";
   };
 
   deps = with depot.third_party; [
diff --git a/third_party/gopkgs/google.golang.org/grpc/default.nix b/third_party/gopkgs/google.golang.org/grpc/default.nix
index f3ed89d092..522a27d602 100644
--- a/third_party/gopkgs/google.golang.org/grpc/default.nix
+++ b/third_party/gopkgs/google.golang.org/grpc/default.nix
@@ -1,10 +1,12 @@
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
 depot.nix.buildGo.external {
   path = "google.golang.org/grpc";
-  src = builtins.fetchGit {
+
+  src = pkgs.fetchgit {
     url = "https://github.com/grpc/grpc-go";
     rev = "085c980048876e2735d4aba8f0d5bca4d7acaaa5";
+    hash = "sha256:1vl089pv8qgxkbdg10kyd7203psn35wwjzxxbvi22628faqcpg61";
   };
 
   deps = with depot.third_party; [