about summary refs log tree commit diff
path: root/third_party/gopkgs/google.golang.org/grpc/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-13T12·12+0000
committerVincent Ambo <tazjin@google.com>2019-12-13T12·12+0000
commit9594203e07f51541b56ac08c752d5f30ec2d2de2 (patch)
tree541239e848f904230e211c540f604866e6e90373 /third_party/gopkgs/google.golang.org/grpc/default.nix
parent8b10c8d0f3c60b480c7d69dcfff2a9c974c56b89 (diff)
feat(third_party/gopkgs): Import external packages for Google Cloud r/123
These packages contain the Cloud SDK for Go. There is currently a
linker issue (presumably due to something in `buildGo.nix`) that means
that projects using them can not actually be built.
Diffstat (limited to 'third_party/gopkgs/google.golang.org/grpc/default.nix')
-rw-r--r--third_party/gopkgs/google.golang.org/grpc/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/third_party/gopkgs/google.golang.org/grpc/default.nix b/third_party/gopkgs/google.golang.org/grpc/default.nix
new file mode 100644
index 000000000000..a8885c4b1e7c
--- /dev/null
+++ b/third_party/gopkgs/google.golang.org/grpc/default.nix
@@ -0,0 +1,21 @@
+{ pkgs, ... }:
+
+pkgs.buildGo.external {
+  path = "google.golang.org/grpc";
+  src = builtins.fetchGit {
+    url = "https://github.com/grpc/grpc-go";
+    rev = "451cf373a706e089ca34abd9ea14cbc20b34c1fc";
+  };
+
+  deps = with pkgs.third_party; map (p: p.gopkg) [
+    gopkgs."golang.org".x.net.trace
+    gopkgs."golang.org".x.net.http2
+    gopkgs."golang.org".x.net.http2.hpack
+    gopkgs."golang.org".x.sys.unix
+    gopkgs."github.com".golang.protobuf.proto
+    gopkgs."github.com".golang.protobuf.ptypes
+    gopkgs."github.com".golang.protobuf.ptypes.duration
+    gopkgs."github.com".golang.protobuf.ptypes.timestamp
+    gopkgs."google.golang.org".genproto.googleapis.rpc.status
+  ];
+}