about summary refs log tree commit diff
path: root/third_party/gopkgs/golang.org/x/text/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-11-21T21·09+0300
committertazjin <tazjin@tvl.su>2022-01-17T14·18+0000
commit1c81ccb99634d107eb7f9b986bc4822c7a517d13 (patch)
treed481efeed953557bb5611c957133194980354251 /third_party/gopkgs/golang.org/x/text/default.nix
parent1d281151dedcfe1795e03755a1cf22b08d96cd30 (diff)
fix(3p): Move away from builtins.fetchGit r/3619
Moves to the derivation-based git fetchers everywhere in third-party.
This might help with forward-compatibility with newer Nix versions,
though that's not our primary concern right now.

Change-Id: I565bb72585b8639893e9ea3a9e233338aede63a9
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3903
Tested-by: BuildkiteCI
Reviewed-by: zseri <zseri.devel@ytrizja.de>
Diffstat (limited to 'third_party/gopkgs/golang.org/x/text/default.nix')
-rw-r--r--third_party/gopkgs/golang.org/x/text/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/third_party/gopkgs/golang.org/x/text/default.nix b/third_party/gopkgs/golang.org/x/text/default.nix
index 33b7444616..f5a900b958 100644
--- a/third_party/gopkgs/golang.org/x/text/default.nix
+++ b/third_party/gopkgs/golang.org/x/text/default.nix
@@ -1,9 +1,11 @@
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
 depot.nix.buildGo.external {
   path = "golang.org/x/text";
-  src = builtins.fetchGit {
+
+  src = pkgs.fetchgit {
     url = "https://go.googlesource.com/text";
     rev = "cbf43d21aaebfdfeb81d91a5f444d13a3046e686";
+    hash = "sha256:1h6z2x4ijzd1126zk3lf8f3bp98j1irs7xg6p8nwpymkqkw5laq8";
   };
 }