about summary refs log tree commit diff
path: root/third_party/gopkgs/golang.org/x/crypto/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-11-21T21·09+0300
committertazjin <tazjin@tvl.su>2022-01-17T14·18+0000
commit1c81ccb99634d107eb7f9b986bc4822c7a517d13 (patch)
treed481efeed953557bb5611c957133194980354251 /third_party/gopkgs/golang.org/x/crypto/default.nix
parent1d281151dedcfe1795e03755a1cf22b08d96cd30 (diff)
fix(3p): Move away from builtins.fetchGit r/3619
Moves to the derivation-based git fetchers everywhere in third-party.
This might help with forward-compatibility with newer Nix versions,
though that's not our primary concern right now.

Change-Id: I565bb72585b8639893e9ea3a9e233338aede63a9
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3903
Tested-by: BuildkiteCI
Reviewed-by: zseri <zseri.devel@ytrizja.de>
Diffstat (limited to 'third_party/gopkgs/golang.org/x/crypto/default.nix')
-rw-r--r--third_party/gopkgs/golang.org/x/crypto/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/third_party/gopkgs/golang.org/x/crypto/default.nix b/third_party/gopkgs/golang.org/x/crypto/default.nix
index dfaf4ac856..41c3b4e726 100644
--- a/third_party/gopkgs/golang.org/x/crypto/default.nix
+++ b/third_party/gopkgs/golang.org/x/crypto/default.nix
@@ -1,10 +1,12 @@
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
 depot.nix.buildGo.external {
   path = "golang.org/x/crypto";
-  src = builtins.fetchGit {
+
+  src = pkgs.fetchgit {
     url = "https://go.googlesource.com/crypto";
     rev = "e9b2fee46413994441b28dfca259d911d963dfed";
+    hash = "sha256:18sz5426h320l9gdll9n43lzzxg2dmqv0s5fjy6sbvbkkpjs1m28";
   };
 
   deps = with depot.third_party; [