about summary refs log tree commit diff
path: root/third_party/gopkgs/go.opencensus.io
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-11-21T21·09+0300
committertazjin <tazjin@tvl.su>2022-01-17T14·18+0000
commit1c81ccb99634d107eb7f9b986bc4822c7a517d13 (patch)
treed481efeed953557bb5611c957133194980354251 /third_party/gopkgs/go.opencensus.io
parent1d281151dedcfe1795e03755a1cf22b08d96cd30 (diff)
fix(3p): Move away from builtins.fetchGit r/3619
Moves to the derivation-based git fetchers everywhere in third-party.
This might help with forward-compatibility with newer Nix versions,
though that's not our primary concern right now.

Change-Id: I565bb72585b8639893e9ea3a9e233338aede63a9
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3903
Tested-by: BuildkiteCI
Reviewed-by: zseri <zseri.devel@ytrizja.de>
Diffstat (limited to 'third_party/gopkgs/go.opencensus.io')
-rw-r--r--third_party/gopkgs/go.opencensus.io/default.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/third_party/gopkgs/go.opencensus.io/default.nix b/third_party/gopkgs/go.opencensus.io/default.nix
index bc14441645..b1ee6da1fc 100644
--- a/third_party/gopkgs/go.opencensus.io/default.nix
+++ b/third_party/gopkgs/go.opencensus.io/default.nix
@@ -1,10 +1,13 @@
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
 depot.nix.buildGo.external {
   path = "go.opencensus.io";
-  src = builtins.fetchGit {
-    url = "https://github.com/census-instrumentation/opencensus-go";
+
+  src = pkgs.fetchFromGitHub {
+    owner = "census-instrumentation";
+    repo = "opencensus-go";
     rev = "643eada29081047b355cfaa1ceb9bc307a10423c";
+    sha256 = "1acmv2f5wz06abphk0yvb9igp2j5sn1v21dg1p8n109rwanwd5v4";
   };
 
   deps = with depot.third_party; [