about summary refs log tree commit diff
path: root/third_party/gerrit_plugins/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-08-28T11·31+0300
committertazjin <mail@tazj.in>2021-08-28T15·32+0000
commitfe225d48a18f722c03e31fdeb9c6c6c4ac6bb9d8 (patch)
tree027383b912447ccaf3b4a0b42e3dbb2c77fad84b /third_party/gerrit_plugins/default.nix
parent0c1b8f954ebecc4fd0db53a559acaaeaa7c80824 (diff)
feat(3p/gerrit): Upgrade Gerrit and plugins to v3.4.0 r/2798
Brings us back to a stable version of Gerrit instead of a random
commit. Note that Gerrit 3.4.1 is out, but due to a bug it can not be
built publicly because it accidentally points at a private
submodule (this is being fixed upstream).

Change-Id: I0376c63a649498cef999dfa99bfccba511f2c8da
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3444
Tested-by: BuildkiteCI
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'third_party/gerrit_plugins/default.nix')
-rw-r--r--third_party/gerrit_plugins/default.nix17
1 files changed, 3 insertions, 14 deletions
diff --git a/third_party/gerrit_plugins/default.nix b/third_party/gerrit_plugins/default.nix
index b4570e7a8a..08a9e17ff9 100644
--- a/third_party/gerrit_plugins/default.nix
+++ b/third_party/gerrit_plugins/default.nix
@@ -6,11 +6,11 @@ in depot.nix.utils.drvTargets {
   # https://gerrit.googlesource.com/plugins/owners
   owners = buildGerritBazelPlugin rec {
     name = "owners";
-    depsOutputHash = "sha256:162hxk2qsix0x1aarhsaqi52q7j7mjpyk8af57w0a012i55ryqqa";
+    depsOutputHash = "sha256:0qx3675lkj241c1sqs6xia5jpcwha2ib3mv32cilmh0k3cwdyyh2";
     src = pkgs.fetchgit {
       url = "https://gerrit.googlesource.com/plugins/owners";
-      rev = "f3335231b98e14664fdd1b325486bb0824800ac3";
-      sha256 = "sha256:0dqf36wn6gnkwia3529dwlcib2np78dgsjs7dymg5isy1i8p655f";
+      rev = "99a9ab585532d172d141b4641dfc70081513dfc2";
+      sha256 = "sha256:1xn9qb7q94jxfx7yq0zjqjm16gfyzzif13sak9x6j4f9r68frcd4";
     };
     overlayPluginCmd = ''
       chmod +w "$out" "$out/plugins/external_plugin_deps.bzl"
@@ -19,15 +19,4 @@ in depot.nix.utils.drvTargets {
       cp -R "${src}/owners-common" "$out/owners-common"
     '';
   };
-
-  # https://gerrit.googlesource.com/plugins/checks
-  checks = buildGerritBazelPlugin {
-    name = "checks";
-    depsOutputHash = "sha256:1262xhl2z1pml6iimhnjm5l3gzddz0rjj6sjq53212dk2dxs5y1b";
-    src = pkgs.fetchgit {
-      url = "https://gerrit.googlesource.com/plugins/checks";
-      rev = "990e936b1e050c4fe7ac3e590bdb5cfff0311232";
-      sha256 = "sha256:0cgrwrimsxx0dnqvp0akv5pz17hy743lhkqvsks60fijb34ps54s";
-    };
-  };
 }