about summary refs log tree commit diff
path: root/third_party/gerrit/default.nix
diff options
context:
space:
mode:
authorLuke Granger-Brown <git@lukegb.com>2020-07-02T22·28+0100
committerlukegb <lukegb@tvl.fyi>2020-07-03T18·18+0000
commit3f6518ce99de8d8fa330ae551b2dc49b2094c712 (patch)
tree57d8abbcfb7225f1360e0d69446817df3ebfe3f1 /third_party/gerrit/default.nix
parent26bb34823d884a619985cf91262f180e0ad4d207 (diff)
fix(gerrit): return HTML titles in more cases r/1199
At present, we don't return HTML titles if there's a trailing slash,
or a patchset. Instead, just consume the / and anything after it.

This also fixes /123, because this is HTTP redirected to the full path
*with a trailing slash* which otherwise wouldn't get the title
injected.

Change-Id: Idfd0e67752880a37dce0b400a3c1cfc53fac2912
Reviewed-on: https://cl.tvl.fyi/c/depot/+/859
Reviewed-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--third_party/gerrit/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/third_party/gerrit/default.nix b/third_party/gerrit/default.nix
index d5350d3ed8..8b7e9678e9 100644
--- a/third_party/gerrit/default.nix
+++ b/third_party/gerrit/default.nix
@@ -40,10 +40,10 @@ pkgs.buildBazelPackage {
     fetchSubmodules = true;
   };
   patches = [
-    ./use_detzip.patch
-    ./syntax_highlight_nix.patch
-    ./syntax_highlight_rules_pl.patch
-    ./add_titles_to_cls.patch
+    ./0001-Use-detzip-in-download_bower.py.patch
+    ./0002-Syntax-highlight-nix.patch
+    ./0003-Syntax-highlight-rules.pl.patch
+    ./0004-Add-titles-to-CLs-over-HTTP.patch
   ];
 
   bazelTarget = "release";