about summary refs log tree commit diff
path: root/third_party/gerrit-queue/shell.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-12-09T13·11+0300
committerVincent Ambo <mail@tazj.in>2021-12-09T13·13+0300
commit59f97332b3076afe80ed3fe92eb0e1da676e3a99 (patch)
tree07e3cb9b1cf29693e3de3f6a2dfcf22bd58ebf92 /third_party/gerrit-queue/shell.nix
parentff10b7ab8303d050a8d7d751611da88bc13a75b4 (diff)
parent24f5a642af3aa1627bbff977f0a101907a02c69f (diff)
subtree(3p/gerrit-queue): Vendor at commit '24f5a642' r/3170
Imported from github/tvlfyi/gerrit-queue, originally from
github/tweag/gerrit-queue but that upstream is unmaintained.

git-subtree-dir: third_party/gerrit-queue
git-subtree-mainline: ff10b7ab8303d050a8d7d751611da88bc13a75b4
git-subtree-split: 24f5a642af3aa1627bbff977f0a101907a02c69f
Change-Id: I307cc38185ab9e25eb102c95096298a150ae13a2
Diffstat (limited to 'third_party/gerrit-queue/shell.nix')
-rw-r--r--third_party/gerrit-queue/shell.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/third_party/gerrit-queue/shell.nix b/third_party/gerrit-queue/shell.nix
new file mode 100644
index 0000000000..7a2d65d596
--- /dev/null
+++ b/third_party/gerrit-queue/shell.nix
@@ -0,0 +1,12 @@
+let
+  pkgs = (import (builtins.fetchTarball {
+    url = "https://github.com/NixOS/nixpkgs/archive/5de728659b412bcf7d18316a4b71d9a6e447f460.tar.gz";
+    sha256 = "1bdykda8k8gl2vcp36g27xf3437ig098yrhjp0hclv7sn6dp2w1l";
+  })) {};
+in
+  pkgs.mkShell {
+    buildInputs = [
+      pkgs.go_1_12
+      pkgs.statik
+    ];
+  }