about summary refs log tree commit diff
path: root/third_party/gerrit-queue/shell.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2021-12-14T16·23+0100
committerclbot <clbot@tvl.fyi>2021-12-14T17·14+0000
commitb3c4057f4bcb770785ba7147e40aa98e38171d08 (patch)
tree180fb293e2bb925bce3753f6c36cbb1f3d21d8f0 /third_party/gerrit-queue/shell.nix
parentb68f7eebb9763c0ea8f135f72026bfb787b78c6c (diff)
refactor(3p/gerrit-queue): use go:embed, bump go1.16, drop shell.nix r/3243
Previously, gerrit-queue used statik to embed files. Since go1.16, we
have go:embed, which solves this much nicer, without any requirements to
have the statik binary around.

As the only other thing the shell.nix and .envrc plumbing did was bring
a version of Go in scope, it's dropped now. We assume to have a
recent-enough go binary around, else go will complain.

Imported from https://github.com/flokli/gerrit-queue/pull/9

Change-Id: I851b06777a29d4f2d955cf3a7db6455a7189bc46
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4329
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Autosubmit: tazjin <mail@tazj.in>
Diffstat (limited to '')
-rw-r--r--third_party/gerrit-queue/shell.nix12
1 files changed, 0 insertions, 12 deletions
diff --git a/third_party/gerrit-queue/shell.nix b/third_party/gerrit-queue/shell.nix
deleted file mode 100644
index 7a2d65d596..0000000000
--- a/third_party/gerrit-queue/shell.nix
+++ /dev/null
@@ -1,12 +0,0 @@
-let
-  pkgs = (import (builtins.fetchTarball {
-    url = "https://github.com/NixOS/nixpkgs/archive/5de728659b412bcf7d18316a4b71d9a6e447f460.tar.gz";
-    sha256 = "1bdykda8k8gl2vcp36g27xf3437ig098yrhjp0hclv7sn6dp2w1l";
-  })) {};
-in
-  pkgs.mkShell {
-    buildInputs = [
-      pkgs.go_1_12
-      pkgs.statik
-    ];
-  }